22 Replies Latest reply: Dec 20, 2012 8:32 PM by jbones RSS

Wifi Calling Problems

kylew 2 Bar

Hey Guys having a few problems with Wifi Calling.

 

1. Echoing when calling on Wifi, stays for a long time have tried to have other caller just wait for the minute or two its supposed to go away but to no avail.  I am on my home wifi network which is over 20 mbs a second so I have a great connection. 

 

2. Sometimes the call drops for no reason when using the wifi calling, this usually happens within the first minute

 

3. Sometimes while on wifi calling the person I am talking to stops hearing me, I can hear them but my audio on my end cuts out. 

 

I have tried turning wifi off and all of these problems go away, but I don't want to do that because the whole point of having republic wireless is to offload onto wifi because we are wifi people.  I know we are in beta but has anyone had any luck with fixing or improving wifi calling.  I tried using google voice to set up the call, calls the other person, calls my phone and we are connected thought the google voice system but still had echo. 

 

Really hope they get Wifi SMS working soon, I am amazed how much I text

  • Re: Wifi Calling Problems
    heavyt 3 Bar

    Have you tried other wifi sites to see if the echo is still happening? Have you tried Google Voice app for texting over wifi?

  • Re: Wifi Calling Problems
    stewie 3 Bar

    Hey Kyle,

     

    You should check out this document for the status and suggested workarounds.

     

    Issue Status: Calls over Wi-Fi may lose inbound audio a few seconds into a call

     

    Seanr updated this document on 9/13 and it appears that a service release should be forthcoming.  There is no firm date at this time for the update as they are conducting final testing, but sounds like it could be soon.

  • Re: Wifi Calling Problems
    southpawkb Ambassador

    Hi kylew,

    First, to improve the general quality of the call, have you tried adjusting the QoS on the router? You want to give your phone priority over the other devices using the router.

    1. Echoing when calling on Wifi, stays for a long time have tried to have other caller just wait for the minute or two its supposed to go away but to no avail.  I am on my home wifi network which is over 20 mbs a second so I have a great connection.

    You don't say what steps you've tried to troubleshoot, or whether you were using speakerphone.

    Have you reviewed these:

    Fixed - Issue Status: Feedback Echo on Motorola DEFY XT?

    Echo or Call Quality Issues Over WiFi

    Echo on Wi-Fi On Speakerphone or Off?

    There's good info in each of them.

     

    2. Sometimes the call drops for no reason when using the wifi calling, this usually happens within the first minute

    For this issue are you talking about the call totally disconnecting and your phone returning to the locked state? Or are you just not hearing the other party?  Go ahead and give some details about what type of internet connection you have, what type of router and firmware, and whether this happens when you are on other networks, or just your home network (as heavyt asked).

     

    3. Sometimes while on wifi calling the person I am talking to stops hearing me, I can hear them but my audio on my end cuts out.

     

    I am having this problem, too. It is the opposite of the Wifi drops voice on cell after 10 sec they can still hear me issue, as far as which direction the audio stops flowing. For me it only seems to happen when the call originates with the RW phone. Calls received to the RW phone do not have this issue.  Is that your observation as well?

    I've seen cbwahlstrom suggest (for some similar issues, but not this exact thing) turning off SIP ALG on your router - Re: WiFi calling incoming and outgoing is not working

    I have not been able to find this setting on my router, but would be very interested in knowing if this resolves the issue for you, and perhaps cbwahlstrom could also weigh-in on this issue. (As I may be totally off the mark here.)

     

    ~~~~~

    SouthpawKB, Optimus owner, not a republic wireless employee

    • Re: Wifi Calling Problems
      cbwahlstrom Ambassador

      If these problems are happening in one WiFi location, for which you have control of the network, the following may (or may not) be of help.

       

      Echo - caused by latency and overmodulation (delay and volume).  There is a good explanation of the causes of echo at Causes of Echo - voip-info.org.  If you are using Google Voice, try turning if off and see if echo improves.  Google Voice can introduce latency to the call path.

       

      Call dropping in first minute - Likely a product of RW switching the call path after the initial call setup (problems also magnified if you have high latency and/or jitter introduced by your ISP).  Turn off SIP ALG, and/or NAT filtering that you find in the router.  If all else fails borrow a router from someone who has a spare of a different model than your own and see if that helps.

       

      Voice cut out - Caused by latency, jitter, packet loss.  Same fixes as above.  If the problem is introduced by your ISP, however, there's not much you can do but contact your ISP.  Check your network connection for VOIP potential quality by running a test from a VOIP test site such as VoIP Test | OnSIP.  It's quite possible, that with the three of these problems occurring, you have an ISP induced problem.

       

      The ultimate would be to get RW to enable SIP logging on your account.  I don't know that they will do that for you, but it doesn't hurt to ask.

       

      Disclaimer - I'm not a network engineer by any means, most of this stuff is based on half a dozen years of experience being a VOIP hobbyist (take it for what it's worth...my 2 cents).

      • Re: Wifi Calling Problems
        southpawkb Ambassador

        Hi cbwahlstrom,

        I'm going to prod you a little here, on the one issue that kylew and I share, and if kylew wants it in a separate discussion from his own, it can be "branched" to a new one. I think it's relevant to the topic, though.

         

        I've been trying all these suggestions you post, to remedy my issue with the loss of outgoing audio.

        I'm not having much luck. (Have not borrowed a spare router, yet.)

        I use a Linksys WRT54G v6.  It runs the native firmware, v 1.00.7

        I can't find any option anywhere to turn off SIP ALG.

        Filter Internet NAT Redirection  is unchecked.

         

        Here are my results from the test you recommended:

        • Re: Wifi Calling Problems
          stewie 3 Bar

          Hi Southpaw,

           

          Forgive me for jumping in here but I could not help but notice we have similar routers.  I'm connected through the WRT54GS model, which is basically the same unit with a slightly different Broadcom chip.  It works fine with my Defy XT and your test results are better than mine.

           

          The WRT54G is a Stateful Packet Inspection (SPI) firewall and it does not have a place in the firmware config screens to enable/disable that function, at least in the native firmware.

           

          I took a look at Cisco's site for more info about this model and found a couple of things you may already know and have reasons for them.  The first thing I saw was that you are 10 versions of firmware upgrades behind.  There is a very long list of changes they have made since the original release. The latest version is from 10/2009.  Product: WRT54G v5 and v6, Firmware Release History

           

          Suggestions you might try if you have not already:

          • Update the firmware to the latest version.  (After fully backing up your current version and settings).
          • Turn-off everything connected to your router and disable the router firewall on the config page.  This will effectively disable the SPI function since the firewall will be disabled. (This is not something I would recommend except in extreme instances where you just have to know).
          • Try the phone with each scenario above.

           

          Just some thoughts of mine since I don't know what you have tried already in the past.

           

          -S-

          • Re: Wifi Calling Problems
            southpawkb Ambassador

            Thanks stewie,

            Probably worth taking the time to do. I haven't tried anything so far except for fiddling with the settings on the router in the original  firmware.  It'll have to wait til Tuesday, but I'll let you know if it helps.

             

            ~~~~~

            SouthpawKB, Optimus owner, not a republic wireless employee

          • Re: Wifi Calling Problems
            cbwahlstrom Ambassador

            I welcome the jumping in.  I think the advice is really sound.  The WRT54G v6 had terrible problems with VOIP registration below firmware version 1.00.6.  I imagine many more enhancements have been made in subsequent firmware versions.

    • Re: Wifi Calling Problems
      kylew 2 Bar

      yes the only time I have problems is when I call someone from my rw phone, it drops the call completely or they stop hearing me. 

  • Re: Wifi Calling Problems
    kylew 2 Bar

    Hey guys, I lowered my volume and it has helped a ton!!!!! Now my caller no longer hears the echos.  Thanks a ton!  My dropped calls have also stopped happening.

  • Re: Wifi Calling Problems
    heavyt 3 Bar

    I am finding that some public Wifi sites, like Uno's pizza, when I make/receive calls they will connect but within 45 seconds I  lose audio but the other party still hears me. But if I make this same call with my Nokia 810 internet tablet (linux base voip sofware) the  audio does not drop.

    • Re: Wifi Calling Problems
      cbwahlstrom Ambassador

      The VOIP provider you use on your tablet likely is proxying the media stream, while Republic Wireless uses a SIP re-invite command for a direct media stream.  The re-invite directed to a different IP address likely causes audio drop when misinterpreted by the router.  There's likely no fix at a public WiFi spot (unless you can gain control of the router and fix it).  Most of the hard to fix WiFi calling problems with RW are due to this sip re-invite, but it does generally improve latency issues.

      • Re: Wifi Calling Problems
        jbones 3 Bar

        cbwahlstrom or billmeek Any of you have any suggestions on how to set up a WRT54GL Linksys router? I have it set up right now with stock firmware and Qos set to MAC priority on both phones set to High. I'm getting choppy talk going out of my handset to others on the other end that I speak to. Seems to be mainly to landline numbers, but not completely consistent either. To cell phones it seems to work pretty well. My Speed is 1.5 download/256kps upload. Any suggestions that would help this?

        • Re: Wifi Calling Problems
          cbwahlstrom Ambassador

          256K upload?  This isn't satellite internet, is it?  If it is, I'm not sure anything will help.  If not, take a look at this page setup by a vonage user who has been playing around with the WRT54GL to optimize QOS:

           

          WRT54GL QoS Configuration

           

          It would also be helpful if you could post some VOIP test results from a site such as:

           

          VoIP Test | OnSIP

           

          Bandwidth.com also has a test site, but it's always broken when I try to use it:

           

          VoIP Test - Is Your Connection Fast Enough? | Tools | Bandwidth.com

          • Re: Wifi Calling Problems
            jbones 3 Bar

            Nope DSL. Is that speed a problem. Just saw your post ...thanks, will try that link

            • Re: Wifi Calling Problems
              cbwahlstrom Ambassador

              256K is fine for VOIP, unless you have lots of other network traffic at the same time.  Of course, this is what QOS is designed to help with.  I'm not all that sure how well the QOS on your routers firmware actually works though.  I posted some links to VOIP testing sites while you were replying to my last post.  Please try running one of these and posting your scores.

            • Re: Wifi Calling Problems
              homelessonwheels 3 Bar

              Mine is working fine on 1.5M down, 750K up DSL.  I think low-end DSL will be OK if you don't have a lot of other traffic going on at the same time (streaming music or especially video, or large up/downloading, including bit torrent). The problem with a slower connection is that there's less bandwidth to share. I'm not sure what codecs they are using, but I imagine it uses 32-64 K in each direction.

              • Re: Wifi Calling Problems
                jbones 3 Bar

                Thought I would update this post with these results. I upped my download and upload speeds and there are night and day difference over WIFI. I also updated the firmware to DD-WRT on my router and left the default settings. Just had a conversation for 1.25 hours without a hitch. Awesome!!!

        • Re: Wifi Calling Problems
          glarepate 4 Bar

          I have the WRT54GS and most of the QoS settings only apply to wired devices.  Take a look at all the screens for your router as there are a lot of variations and models that are slightly different.  On my router the only QoS settings for wirelss devices are WMM (WiFi MultiMedia extensions) and No acknowledgement.  They are described on the router setup page thusly:

           

          Wireless QoS

           

          Wireless QoS is also referred to as Wi-Fi MultiMediaTM (WMM) by the Wi-Fi AllianceTM. Select Enable to utilize WMM if you are using other wireless devices that are also WMM certified.

           

          No Acknowledgement : Enable this option if you would like to disable acknowledgement. If this option is enabled, the router will not re-send data if an error occurs.

          ________________

           

          Nothing I have seen indicates that these phones support these protocols.  And no combinatiopn of settings has made a detectable improvement in call quality so far.  But i am starting to test it again now.

        • Re: Wifi Calling Problems
          billmeek Ambassador

          Some landlands these days are actually VOIP connections.  It's possible that the issue you are seeing is unrelated to router. 

           

          The first thing I'd do is test the connection using a free account from VoipSpear.com and check the MOS over a 6 hour period.  If there are no connectivity issues, I'd put a 3rd party firmware on the router such as DD-WRT (my preference) or Tomato.  I've had much better luck with the 3rd party firmwares than any stock one.  The GL series is the same as the earlier G series routers that were often bought for aftermarket firmware up until v5 models when they changed the specs on the hardware.